Jump to content

Rt4 Radio Failure, Cd Update Then No Sound, Recovery


Recommended Posts

I've had a bit of trouble with my RT4...any advice would be appreciated!

This week my C5's RT4 system began to skip and pause when playing from the Jukebox and from CD. I performed a reset or two hoping that re-booting would cure the problem. It didn't – and eventually it started rebooting itself and performing hard drive checks until eventually a 'please insert upgrade cd' message appeared - accompanied by the usual start-up logo and car silhouette...and it wouldn't do anything else.

Suspecting corruption of the hard drive, I bought an external IDE drive case so I could connect it to Disk Utility on my computer and check the drive. I wasn't provided any software disks when I bought the car either, so I took the opportunity to back-up the contents of the disk.
I didn't find any errors, but verified and repaired each partition anyway.

 

Anyway – I re-assembled the unit and plugged it back in the car, but the message asking for the upgrade cd was still there.

Next, after some research, I downloaded a system upgrade file named CD_RT4-5_SW_8.31.iso (I don't know what edition I was running before because I wasn't able to check) but this seems to be the latest I could find.

 

The update has worked (new Citroen Logo appearing) but I get a message saying that emergency calls are disabled (I don't have a sim in the car but I've never had this message before) and I'm getting no sound whatsoever through the speakers. No parking sensor beeps, no music, no speech. Also (and I'm not sure if I'm imagining it) the resolution of the display looks lower. The option in the menu for the video camera connection has also disappeared.

 

Are these things that need to be re-activated with Lexia? Or am I missing something?

Thanks for reading!

 

Kind Regards

Scott

Edited by Scorchy
Link to post
Share on other sites

The following is a list of things to be configured, taken for a mark 2 C5 2.2 hdi estate as an example. Your lack of sound may be due to these but I am not sure. Others on here have tried updates before but not mentioned the lack of sound afterwards.

 

6.2. Table 2 : Radio ECU - Radio configuration



 

Configuration parameters / Valued to be configured / Comments  

 

- Geographical area of use / - / Country

- CD changer or USB BOX / absent or present / Check the absence of : CD changer (or accessory USB Box) in the vehicle (boot, glove box, fascia control panel, under the passenger’s seat, armrest) 

-  Fader function / activated (2)

-  AM waveband / activated (2)

- Volume automatic control / Active (2)

- Hi-fi amplifier  / absent or standard amplifier / Check the absence of an amplifier located under the passenger’s seat or above the glove box trim

- Volume level correction law / Characteristic no. 1 / (2) Defines the level of correction of the volume in relation to the speed of the vehicle (Laws n°1 to 5 available)

- Lo/dx sensitivity curve / Graph N°1 / (2) Defines the LO/DX sensitivity curve for searching for radio frequencies (curves No. 1 to 3 available)

- Radiotext function / activated / (2) Displays the information provided by the station being listened to (Review, title and author of the song, etc.)

-  CDtext function / Deactivated / Check the presence of a single-tuner radio, a single aerial connector visible at the rear of the audio equipment (Specific part number)

- CDtext function / activated / Check the presence of a dual-tuner radio, two aerial connectors visible at the rear of the audio equipment and/or of the MP3 function (Specific part number)

- Parking assistance / absent / Check the absence of the parking assistance sensors at the front and/or at the rear of the vehicle

- Parking assistance / Present / Check the presence of the parking assistance sensors at the front and/or at the rear of the vehicle

- Auxiliary input n°1 / Absent / No external source available on the auxiliary input n°1

- Auxiliary input no. 1 / Reserved for the hands-free kit / (Hands-free kit) Check the presence of the Citroën hands-free kit to the right of the heating unit, under the vehicle’s fascia panel

- Auxiliary input n°2 / Absent / (2)

- Steering wheel with fixed central controls / absent / (2)

- Sound level of the signal emitted for the front parking assistance / Volume No. 4 / (2)

- Sound level of the signal emitted for the rear parking assistance / Volume No. 4 / (2)


 

(2) Configuration of another value prohibited.


Link to post
Share on other sites
  • 2 weeks later...

Update!

I experienced some problems with my Lexia (corrupt software I suspect) so I've resorted to Mirascripts to reconfigure my system. It's taken a bit of experimentation but I've managed to get it all working again except for two things...

A)The 'list' button on the steering wheel hub no longer works - the same button on the head unit does however.

B)I no longer get location info relayed to the drivers display on the central dial. Street names etc appear on the main display but 'unmapped area' appears on the speedo, though the compass, altitude and navigation instructions all appear as they should.

 

I'm wondering if these are lexia only configurations, in which case I'll have to try to get mine working again.

Any advice would be gratefully received!

 

Thanks

Scott

Link to post
Share on other sites
  • 1 year later...

Hello.i have bought a car recently, everything seemd to work fine, until it appeard on the screen suddenly "please insert update cd". I was at Citroen and they put a cd inside but the update could not be made and the cd remained inside. I searched a little bit on the Internet and I found how to hard reset myself and I succeeded. On the screen appears new logo, but there is no sound. No parking sound, no radio sound, nothing. I was at Citroen again, as I looked on this topic and I thought it will solve with lexia but they could not seem to make it work. How you solved your problem?! I desperate need some help

Link to post
Share on other sites

Welcome to the forum.

 

I have changed the topic title slightly to better reflect the problem since it may attract more replies. You could try a message to Scorchy since he has not been on the forum since this topic and this way he will get an email. Move your mouse pointer over his name then click on send message. I have deleted your similar topic to keep any replies together.

Link to post
Share on other sites
  • 1 month later...

Hello.i have bought a car recently, everything seemd to work fine, until it appeard on the screen suddenly "please insert update cd". I was at Citroen and they put a cd inside but the update could not be made and the cd remained inside. I searched a little bit on the Internet and I found how to hard reset myself and I succeeded. On the screen appears new logo, but there is no sound. No parking sound, no radio sound, nothing. I was at Citroen again, as I looked on this topic and I thought it will solve with lexia but they could not seem to make it work. How you solved your problem?! I desperate need some help

Maybe not much of a help, but if your car is fitted with a Hi-Fi system it won't play sound if radio's ECU is set to standard system (no amp)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...