Jump to content

C4 Wheel Centre hub decal


Recommended Posts

I have lost one of my rear centre disc/decals from my C4 Picasso. I ordered spares off ebay 60mm, but fitting them is turning out to be a challenge. These are made from a hard plastic which should just push on. There is no flex on the plastic insert clips and they are quite brittle. I've managed to ruin 2 so far trying to fit them when the clips snapped off.

Do I have to take the wheel off to fit? Would this even help? Are the genuine parts made of metal and more flexible ? I can't even see them on the citroen website.

 

Any thoughts advice or pointers to where I can buy the correct part would be appreciated..

Link to post
Share on other sites

You could try a bit of washing up liquid on the wheel/plastic part to help it slip into place. Warming it a bit in hot water might also make it less brittle. If you do not succeed, try a Citroen dealer for the correct parts. We had a C4 with plastic discs in the wheels and they were not metal.

Link to post
Share on other sites
On 11/21/2021 at 2:04 PM, paul.h said:

You could try a bit of washing up liquid on the wheel/plastic part to help it slip into place. Warming it a bit in hot water might also make it less brittle. If you do not succeed, try a Citroen dealer for the correct parts. We had a C4 with plastic discs in the wheels and they were not metal.

Cheers Paul, I'm passing a main dealer today gonna pop in and ask the question see what they say.

Link to post
Share on other sites
On 11/21/2021 at 2:04 PM, paul.h said:

You could try a bit of washing up liquid on the wheel/plastic part to help it slip into place. Warming it a bit in hot water might also make it less brittle. If you do not succeed, try a Citroen dealer for the correct parts. We had a C4 with plastic discs in the wheels and they were not metal.

I have a 2013 C4 Picasso Airdream Eco Platinum,a really nice car,I think,white,with black trims and roof.

My alloy wheels have a smaller plastic wheel disc,which clips inside the main wheel,and locates on a small extrusion first,before pushing it in to lock on the clips.

I couldn't get the cover to match up on this extrusion,so I snapped it off first.

The cover then pushed in,and locked on the alloy wheel,and has stayed there,no problem!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...