Jump to content

Electrical advice please


Recommended Posts

Hi all,

Hope you maybe able to help.

Wife's car has developed the following issues, all probably minor to most, but still there and rather annoying:

Interior light not working, Seatbelt off warning not working, Headlights on warning not working, Stereo not working.

These have all occurred since we found water in the interior light which, through Youtube, we found to be the aerial mount leaking. Have dried out the condensation caused and fitted a new interior light but still the above are not working. Fuses behind steering wheel all OK, 12v Socket works ok but not the listed items.

Anybody had this or have knowledge please? Most important is stereo, although I am tempted to try aftermarket in there, but if it is a wiring/supply defect then new stereo wont work either.

Any help would be greatly received, thanks.

   

Edited by mrlabbo
wording change
Link to post
Share on other sites

If they are all related then maybe they share a common earth point that has rusted. As a test you could try an earth wire direct to the light since that might be the easiest to access. At the light if you have a ohm meter you could check the resistance between the light negative side and the bodywork which could also check for a good earth.

Link to post
Share on other sites

Sorry for the delay, work has kept me away from the forum and the car. I tried an aftermarket stereo which powered up perfectly but decided on a second hand unit C1 from ebay as didn't have the cage and surround for the other one. 

The replacement arrived today and doesn't work either. Is there anything I am missing as the C1 units are unfused but the aftermarket was a fused unit, would that make a difference???

 

Link to post
Share on other sites

For the after market radio did it just connect to the existing radio connector without any additional wires ?

Citroen radios are coded to the original car and if put in another one need the VIN of the car to be coded to the radio with a dealer diagnostic so it works without beeping.

I do not know the year of your car but a look in the handbook for a 2008 model shows fuse 11, 15amp at the left side of the instrument panel is for the radio and 12 volt socket. Your 12 v socket is working but not the radio - have you checked if there is 12 volts at the radio - if not then the radio wire might be damaged/have a corroded connection or the engine fuse box fuse might have failed. If there is 12 volts at the connection then the earth wire from the radio is suspect - you could try a temporary earth wire to the radio and see if it then works. I believe Haynes do a workshop manual for the C1 and it will have wiring diagrams and they usually list the earth points. This info would help your checks.

In the engine fuse box it lists fuse 7, 15 amp also as for the radio plus the courtesy lamp, speedo/rev counter - have you checked if this fuse is ok ? It could be the Citroen radio has 2 separate 12 volt supplies.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...