Jump to content

Xm V6 Running Problems


Recommended Posts

Dont laugh I know, but I have had this car for years and its been a good workhorse, about a year ago slight misfire or flat spot started, and it gradually over the year got worst, during this time I have replaced what I can this include the following

 

Dist,cap,rotor,leads,plugs

Coil, Tranistorised ign module

Idle speed regulator

Ign ECU

Inj ECU

 

Its a 92 V6 SEI 12V Manual Estate.

 

It never has the fault when cold but as the needle reaches the 90 mark it will start,

I never loses Idle, and can drive through it to about 3000

Its a throttle position fault rather than revs related but comes in on normal driving at 1800 RPM.

Its a smooth cut like a revlimiter, you can feel the engine move on the mountings, it looses all the cylinders.

 

The Citroen Diagnostic computer displays no fault found or recorded, and the throttle switch test passes.

I have kept driving it the hope it will die and the fault can be fixed.

 

Its had the mod to the block connecter under the LHM resovoir, and I have broken and cleaned most engine loom connectors.

 

Does this ring any bells with other V6 owners? Am I the last one left?

Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...