Jump to content

Search the Community

Showing results for tags '1.6VTi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Share Vids And Modifications
    • Citroen C2 vids
  • General Area
    • General Discussion and Nonsense
    • New Member Introduction
    • Fun and Games
    • Questions about Citroen the Company
    • I.C.E (In Car Entertainment) Discussion
    • Petrol Diesel & LPG Injection
    • Insurance
    • Technology Chat
  • Media Area
    • Members cars.
  • Current Citroen Models
    • Citroen DS Range
    • Citroen C1 Forum
    • Citroen C3 Forum
    • C3 Pluriel
    • Citroen C4 Forum
    • Citroen C5 Forum
    • Picasso
    • Berlingo Multispace & Van
    • Dispatch
    • Relay
  • Other Citroen Models
    • Citroen C2 forum
    • Citroen C8 forum
    • Citroen XM Forum
    • Citroen 2CV Forum
    • Citroen AX Forum
    • Citroen BX Forum
    • Citroen DS Forum
    • Citroen Dyane Forum
    • Citroen Xantia Forum
    • Citroen ZX Forum
    • Citroen Saxo Forum
    • Citroen Xsara Forum
    • All other Citroen models
  • Other Clubs and forums
    • Ford Galaxy Owners Club & Forum
    • Citroen Picasso Owners Club

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I have a 2013 C3 Picasso Exclusive with the 1.6VTi 120 engine and EGS6 gearbox. Recently, I've noticed the cabin heating is....pathetic..... with lukewarm air coming from the vents with the knob set to "Hi" , the blue engine temperature warning lamp takes about 8 times as far to go out as it used to (12miles as opposed to 1.5) and the Mpg figure has dropped from a lousy 43mpg to a catastrophic 38mpg. I believe the engine is not getting to the correct temperature and the engine is running rich as a result, the cabin heater isn't being fed with water hot enough. This suggests a problem with the
×
×
  • Create New...