Jump to content

Recommended Posts

just changed the dreaded pressure regulation and lock up electro valves on my c8's al4 autobox along with the complicated ATF change. I also set the counters back to zero via lexia. took it for a spin and the results are perfect running like a new car. I am new to this particular forum and am aware from previous forums i have been a member of that the sharing of information and outcomes is important so if anyone is experiencing these issues then i would be more than glad to help and have plenty of notes on this procedure. When I was on my test run I did notice that my led screen was showing a discrepancy between gears i.e if I was in drive the led would say neutral. I now no that this is the multifunction switch needing adjusting it had no baring on the drive what so ever it was faultless. I just wanted to know if anyone on here had done this procedure and had any tips for me before I attempt this tomorrow.

 

kindest. 

Link to post
Share on other sites

I did, there are a couple of threads about AL4 GearBox, here is one:

http://www.citroen-owners-club.co.uk/citroen/topic/23818-c8-2003-auto-gearbox/

 

and here is the Switch adjustment:

http://www.peugeot206cc.co.uk/repair-206/206/info/gb/b2cg79k3.htm

 

Watch the video and follow the instructions in the above manual, you don't need to remove many parts other than the air filter. 

 

However, if you have not touched the switch during the valves replacement, then I suspect the reason is that you did not place the springy arm correctly (11:12 in the video). It actually has an adjustment tool. But if the shift is insignificant, then adjusting the switch will do the job.

Link to post
Share on other sites

Hi and thank you for your reply some useful info there, the replacement of the electro valves was done to the T and like I said the gear box is operating better than it ever has I have just noticed on this paper https://www.petrila.net/repair/2/406d9/info/gb/b2cg6sk3.htm that it states the adjustment of the multi functions switch is imperative after replacement of the electro valves so I will now follow your paper and report back to you tomorrow and see if it worked thanks so much again.  

Link to post
Share on other sites

Just an update on this completed the multi function switch adjustment and eveything is brilliant,  really pleased with the outcome took me around 30 mins start to finish quite easy actually although the paper looks the complete opposite. Thanks for your imput SIMPLE really helped out if i can help anyone out with any of the stuff mentioned in this thread then let me know and i will try to assist. Thanks again.

Link to post
Share on other sites

I am glad it worked for you. I had to change the â€œBitron S10HD Micro-Switch†inside my MPLS (Multifunction Switch) and replace it with Honeywell Micro-Switch “V15T16-CZ100A05-Kâ€. 

 

I was quite sure that I posted the procedure on this site, but cannot find it. However, here it is:

http://cartechnology.co.uk/showthread.php?tid=20557&highlight=parking+sensors

 

It may come helpful to you or other users.

Link to post
Share on other sites

I have read this topic but since I have not had an auto it means nothing to me other than it is worth pinning since the info is excellent. To help others and searching though the title could be improved - do you have any suggestions ?

Link to post
Share on other sites

Hi Paul,

If you wish to tidy the thread, feel free to edit my contribution and add the following procedure (to your liking) instead of referring to external sites, other users may not be able to see the photos. I have attached a zip file with photos.

 

I remember writing a full procedure about the subject including using the Lexia VCI to monitor the temperature while changing the ATF (oil). Alas, it has been sometime now and could not find it. However, here is the text for the Multifunction Switch:

 

 

The Parking Sensors on my Citroen C8 with an AL4 Automatic gearbox suddenly stopped working. Lexia reported that they are deactivated, I also found that the Reverse Lights were not working either.

 

This is a brief "How To" in case someone faces the same issue:

 

Having checked all connections and fuses, the only suspect component was the Multi-Function Switch (MPLS #252927), positioned on top of the AL4 gearbox, below the air filter. The dealer quoted 120 Euros for the part; I decided to have a go at it.

 

To remove the MPLS (having removed the air filter), remove the gear shift linkage to the gears selector, the 2 Torx screws and connector from the harness on top of the gearbox. Unscrew the little Torx screws to access the Multi-Function Switch (MLPS) and remove the cover. Inside the MLPS there is a 2 legged “Bitron S10HD Micro-Switch†with a specially shaped plunger. This unit connects power to the revers lights and Parking Sensors when the gear is in reverse position.

 

The Micro-Switch can be tested using a “continuity tester†to the two legs and pushing the plunger few times. Mine was pitted and gave a noisy signal indicating weak connection. There is a reach adjuster in case the lever is not pushing deep enough. Pull the Micro-switch out and carefully split the cover open (using a sharp knife) and examine the contact points for pitting or damage (do not clean using sand paper, this damages the coating).

 

The “Bitron S10HD Micro-Switch†was difficult to locate on the internet, but managed to obtain its specification sheet. Basically, what is needed is a 10 Amp, 125 Degrees Celsius and 0.6-1.0 newton (plunger activation force, about 60-100 grams). An equivalent would be the Honeywell V15T16-CP100 or V15H16-CP100 (could not locate at the time). But I found an SPDT (3 legs with lever) Honeywell Micro-Switch “V15T16-CZ100A05-K†with similar spec (around 3 Euros from Farnell/free delivery). I used the plunger from the Bitron, but needed to slightly file the cover to allow the plunger slide easily.

 

De-solder the Red and Orange wires from the faulty part and solder them in the respective legs of the new part, replace into position and test; if all is well, reassemble everything back ensuring correct MPLS "Neutral" positioning.

 

It has been running reliably for more than a year.

reverse switch1.zip

Edited by Simple
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...